Maya Basics

Maya Interface

Here is the basic Maya Interface:

**Menu Bar**


Module Specific Menus – Vary based on the Maya module in which you’re operating. For example, you’ll have various polygon manipulation menus when in Modeling, and texturing tools when in Rendering.

**Status Line**

Module selector – Let’s you change which Maya module you’re using. We typically use Modeling, Animation, and Rendering.

Scene Icons – basic New, Open, and Save icons.

Selection Mode – Let’s you specify how you want to select parts of your scene. By object, or By Component type.

Selection Masks – Assuming you’re selecting by component type, these buttons allow you to specify the component on which you’d like to focus.

Snap Modes – Can be helpful in creating uniform layouts. Essentially objects etc… that you create will move to discrete coordinates as defined by a grid.

Render Buttons – Shows you what your scene looks like when fully rendered.

Show / Hide Editor Buttons – Lets you control what is seen at the screen’s far right by toggling between the various channel box / tools settings modes.

**Shelf**

Filled with helpful buttons to help you create various objects or perform operations. A good place to put shortcuts to commonly used, or custom tools.

**Workspace**

The “main” window in Maya wherein you perform most of your work.

Panel Menu – allows access to various settings related to that particular panel, including what is shown in that panel and “how” it is shown.
Grid – Represents Maya’s Cartesian coordinate system. Shows you where you’re origin is. Gives and idea of the absolute size of things as well.

Axis indicator – In perspective view, shows you the direction your camera is facing. Remember X=red, Y = green, Z= blue.

Camera View Indicator – Tells you which camera that panel is displaying.

Channel Box
Displays parametric information concerning whatever object you currently have selected. Sometimes this space will be occupied by Tool Settings information which controls the parameters of whatever tool you’re using at that time.

Note that when you create a polygon sphere, 5 tabs pop up in the channel box. These are:

PSphere1 – This is a node that contains transformation, pivot, and bounding box info on your primitive. Change this name whenever you create something.

PSphereShape1 – This contains parameters related to the MESH of your object.

PolySphere1 – This is the underlying geometric data of your primitive. Where you control its radius, subdivisions, etc...

Initial Shading group 1 – this is a default collection of notes that determine how your object will render.

Lambert1 – this is the default material for new objects. This will change once you add your own material. Though be sure you refresh the channel box to see this change.

Tool Box
This area contains a collection of manipulators you can use to perform actions such as move, rotate, and scale. Often if you select a tool from a menu, its icon will show up here at the bottom.

Command Line
Allows you to enter MEL (Maya’s scripting language) commands. Yikes!

Help Line
Will give you context sensitive information depending on the task at hand.

Time Slider
Shows you where you are in time when animating.

Layer Editor
We don’t typically use this, but you can create various layers if that’s helpful.

**Basic Modeling Techniques**

Naturally, there are multitudes of ways to model something in Maya. Most of the art lies in analyzing the geometry of your target and determining how a composition of various elements could achieve your objectives.

**Primitives**

The most basic element of most models is a geometric primitive such as a cube, sphere, cone, or other. Maya has 3 modes for creating and working with geometry: Polygons, NURBS, and Sub-Division Surfaces. We will mostly be working with polygons and NURBS. SD Surfaces are sort of a hybrid of both.

**NOTE: All geometry you create in NURBS MUST be converted to Polygons before exporting to Virtools.**

It is possible to create simple models with nothing but primitive geometry by moving, rotating, and scaling.

**Deformers**

Also note that you can put various “deformers” on primitive polygon geometry. For example, create a simple polygonal cylinder. Make sure it is selected. Go to the Deformation Section of the “shelf,” and select “non-linear bend.” This will create a “bend deformers.” From the Tool Box, hit the Show Manipulator box (usually the one at the bottom), and on the Bend1Handle tab in the Channel Box be sure you check Display Rotate Pivot, and Display Scale Pivot. Then you can click on the various control points of the deformer and move them. You can also move, scale, and rotate the entire deformer to change the way it interacts with your mesh.
**Vertex Manipulation**

A lot of highly detailed modeling takes place at the “component level” of polygonal geometry. So if you create some sort of primitive, and hit “select by component” in the status line, you can then directly manipulate the primitive’s various parts to create highly customized shapes. Note what happens when you move, scale and rotate various parts of your shape. If you get the error message, “Some elements cannot be moved (or rotated or scaled) in the 3D view,” RMB on that element’s selection mask in the status line and make sure it’s type is selected in the little list that pops up.
Extruding

While you can accomplish a lot pushing vertices around, there are times you might want to create a significant amount of geometry from a part of your initial primitive. To do this select a face (or other component type), and use the extrude tools found under the edit polygons menu.
You’ll notice a manipulator gizmo appears that lets you move the face along the various axes. As it moves a new “appendage” is created for your model. You can make multiple extrusions along a length to give modeling flexibility later, and even rotate the face while you’re extruding to make curved appendages.
Combinations

There are lots of situations in which you’ll want to attach 2 pieces of geometry together. Of course Maya provides many ways through which you can accomplish this.

Combine – perhaps the easiest way to make 1 mesh out of 2 is to select them both and hit Polygons - > Combine . This simply lumps 2 meshes into 1 poly surface, and doesn’t do anything to actually weld the geometry together. Using this technique extensively can produce meshes that have “internal” polygons that will never be seen, which is inefficient from a rendering perspective, but not a huge concern in this class. It can also make for extremely complex meshes which can make later modeling tasks more complicated.

Booleans – Boolean operations are a versatile way to combine meshes or alternatively subtract one shape from another. For example, to combine a cone to a cylinder, select them both, then hit Polygons->Booleans->Union.
Notice that the resulting geometry is free of redundant polygons. For example the bottom of the cone ceases to exist at the point it intersects with the cylinder.

You can also use Boolean transformations to cut away part of an object. For example to punch a hole through a sphere, create a sphere and a cylinder of appropriate dimensions. Position the cylinder so that it penetrates all the way through the sphere. Shift-Select the shape you want to remain first (the sphere in this case) and the surface to subtract second (the cylinder). Then select Polygons->Booleans->Difference.
The result is pictured below.
The last combination technique we'll discuss briefly is stitching meshes together by combining edges or vertices. So if you created 2 cylinders and wanted to sew them together, first select them both, then hit Polygons->Combine. Then you can hit “Select by Component” and choose vertices. At this point it’s a matter of selecting pairs of vertices that you want to weld together by hitting Edit Polygons -> Merge Vertices. Note you can’t just select all the bottom vertices as this will merge them all into a single vertex which will likely compromise the integrity of your shape. Below shows this process partially completed.
Simple Surface Modeling

Sometimes you need to create a complex surface that doesn’t seem to lend itself to a composition of primitive geometry. But perhaps, it does lend itself to some sort of algorithmic generation such as revolving a curve in space. To create and object such as this, start by making a curve in one of the orthogonal views [in this case the front]. You can begin generating curves either from the Create Menu or the Shelf. There are 2 major modes for creating curves: CV [control vertex] curves or EP [edit point] curves. You can read the help for a full explanation of the difference, but suffice it to say, using CV’s is recommended.
This tool allows you to plot out a 2d curve as shown above. Then, simply select Surfaces->Revolve [] to bring up the Revolve property page. Make sure you select the correct axis around which to revolve (in this case the y). And viola! A slightly eccentric wine glass.
Fans of the play-doh spaghetti factory might also wish to note that you can extrude curves along other curves as shown below.
Symmetry

One thing it is often important to bear in mind when modeling is the natural axes of symmetry displayed by the object in question. Often it is much easier to just model part of something and then duplicate that part elsewhere in your model. This becomes particularly important when modeling characters which generally have some sort of bilateral symmetry which must be reflected in your model in order for them to animate well. For example, let’s say we want to make a simple insect shape by combining legs with a sphere. Assuming the legs don’t need to be different, you would make something like this by combining and duplicating a series of cylinders:
Then you want to combine all these elements into one mesh. Then, delete the faces on the side of the hemisphere with no legs.
Duplicate the resulting mesh, and rotate it so that it makes a full sphere with 6 legs. Finally combine the two meshes to create our lovely insect.
Basic Materials and Textures

Maya provides an astounding array of methods and capabilities to help you color and decorate your models and worlds. Let’s begin with two simple definitions: 1) A Material is according to the Maya help, “a description of what an object looks like when it’s rendered.” For example a material holds data concerning an object’s color, specularity, transparency, and various glow effects. If the object’s color involves having an image, or procedural algorithm mapped onto its surface [we call this a texture], then that is indicated in the material as well. While data concerning an object’s Material is generally accessible in an object’s channel box, one often works with textures from Maya’s Hypershade panel found under Window->Rendering Editors->Hypershade.

Let’s add some textures to a simple geometrical primitive.

**ALWAYS** begin any texturing activity by hitting in the PANEL menu bar Shading->Smooth Shade All and Shading->Hardware Texturing.

If you ever can’t see the results of some texturing operation in one of your panels, it is likely because one of these options is not checked.

Now create a cube. Make sure it is selected. Hit the Select By Component button in the Status Line and then the Select Faces button. Select one of the faces of your cube. Then RMB (right mouse button) to bring up the context menu. Select Assign
New Material, and you’ll see a long list of possible material. Note that you can do almost all of your texturing with Lambert (flat shaded) and Blinn (for specular or shiny objects). Choose Lambert, and you’ll see a new material pop up in the channel box.

The most important element of texturing happens under the “color” line. You can either click on the color box to pull up a color chooser, or click on the little checkerboard next to it, to pull up the texture chooser dialog.
Note that you have a number of different 2d texture options from which to choose.

**CAVEAT EMPTOR:** Virtools only accepts .jpg texture files. So any PROCEDURAL texture created in Maya, including projections of jpegs onto surfaces, must be converted to jpeg file textures before exporting to Virtools according to the procedure detailed below.

For the time being, let’s pick “File.” You’ll notice that parameters for this new material pop up in the channel box including a “file” entry that will bring up a file selection dialog if you hit the “browse” button. Do this and select a .jpg from your hard drive.
If you want to use Maya procedural textures, follow the steps above up until you selected file from the texture dialog. Instead select say the checkerboard pattern.
Note that you can make alterations to how the texture is applied to the surface by manipulating parameters under the place2Dtexture tab in the channel box.
Once you are satisfied with how it looks, do the following: 1) select the face 2) open the hypershade editor 3) shift-select the current material so that both it and the 3d geometry to which it is mapped are selected 4) Hit Edit->Convert To File Texture (maya software)]. This will bring up a dialog box. Be sure you select to convert to a jpg. Also reduce the resolution to the minimum possible to maintain a good image quality. Remember you’re target is a real time rendering engine that will choke on large textures. 128 x 128 is usually a good target. Go up to 256 if the texture is going to be mapped on a large surface that might be seen close up. After doing this, you’ll see that a new material has been assigned to the face, & that material is associated with a file texture.

Imprecations concerning Workflow

Here are a couple hints that should make your work with Maya easier and more productive:

1) Use descriptive names for your shapes and materials. When you create any shape that is going to play a part in your model. At the moment you create it, try to describe its function in the scene, e.g. floor, or upper_arm, or hat. This is especially helpful when you are exporting geometry into Virtools.
2) Save often. Some operations in Maya are not un-do-able. Some operations created confusing effects that are revealed only by later operations. It is unbelievably helpful to have MANY regression points to help you isolate where problems are introduced. I tend to have up to 20 separate versions of even
only moderately complicated models. The rule I use is that any operation worth saving is worth saving as a new version.

3) Do not create what I call involute, by perhaps is more accurately referred to as “interpenetrating” geometry IE this:

4) Do not create non-manifold geometry. See the Maya help for a good definition of this.

5) Experiment with new techniques on simple geometry so that you thoroughly understand their operation before assuming they will work on your lovingly crafted models. Do rough drafts of models using all the techniques you expect to use before spending a lot of time perfecting each step. This will uncover a lot of potential problems early in the process and save many otherwise wasted hours.

6) Export to your target platform (in our case Virtools) EARLY AND OFTEN. There can be subtle disconnects that crop up in the export process. It is always better to learn about these earlier than later.

Export to Virtools

One of the main elements of this class that tends to cause a lot of heartache and confusion is the export process from Maya to Virtools. The important thing to keep in mind is that Virtools supports a robust set of Maya features, BY NO MEANS ALL OF THEM. Almost all problems can be avoided by following imprecation #6 above. You
should also familiarize yourself with the Maya2Virtools export plugin read me parts of which are excerpted below. Here is a basic checklist to follow before your export:

1) Make sure all NURBS surfaces have been converted to Polygons. Modify->Convert->NURBS to Polygons.
2) Make sure all procedural textures or projected textures have been converted to [small!] jpegs.
3) Run Polygons->CleanUp on your meshes.
4) Just before export save a version of your file. Then hit Edit->Delete By Type->History.

Let’s go through the steps to export our cube to Virtools. Hit File->Export All []. This will bring up the export dialog. If it’s not already selected pick the Virtools file export option from the dropdown list. You should then see the following dialog:
Essentially you should always reset to the default setting. And then disable the “enable animation” checkbox if your scene has no animation. NEVER select “store only texture filenames”. And do not export a model as a character unless it is one.

Hit Export All. A file browser will come up asking you where you want the file. Note the file produced is a .nmo file, which is a virtools object file.

You can then open Virtools and select Resources->Import File. Select the appropriate file. Shown below is the import file dialog & what your cube looks like when imported.
Unless you have created lights in Maya, the first thing you’ll want to do is create a point light from the toolbox at left. Then you’ll be able to see the checkerboard texture on your cube. It’s also often a good idea to create a default camera that you can go back to in case something unfortunate happens to your perspective view. Be sure to NAME cameras (and lights) as you create them. You might also want to “set initial conditions” for this camera if you always want it to stay in one place.
Finally, let's add a simple orbital camera so we can interactively inspect our model. Right click on the new camera you created. I named mine “default.” When the context menu comes up, select “Create Script.” Click the arrow next to your new camera. An icon for a Virtools script should appear below it. Double click on this script line. You will then be taken to the Virtools Schematic. From the Building blocks manager in the upper right select Cameras->Movement->Keyboard Camera Orbit. Drag this onto your camera script, and connect it to the leftmost arrow. Double click the Keyboard Camera Orbit building block. A parameters dialog will pop up. Most of these settings you can leave as their default value, but for Target Referential select the name of your cube from the dropdown list.
If you then hit play, you’ll find that you can control the movement of the camera with the keyboard arrow buttons and the page up and page down keys.

Congratulate Self.

Appendix:

ReadMe excerpts:

SUPPORTED FEATURES:

* geometry (mesh, vertices, normals, no constraint of vertices per faces)
* 3D Hierarchy
* skin, smooth skinning and rigid skinning
* morph animations
* vertex color
* uv, and multiple uvsets
* file texture
* layer texture (using file texture)
* visible state of objects (shown or hidden)
* Lambert, Blinn, Phong and Surface Shaders
* shaders, with Texture in Color, Transparency, Ambient Color, Incandescence and Specular slots
* keyframed animation, linear, and bezier for translation keys (tangent type supported : Spline, Linear, Clamped, Flat, Stepped)
* lights
* cameras
* place2dTexture node's parameters (Mirror, Repeat UV, Offset, Rotate UV)
* Rotation pivot
* Shearing for objects without animation
* TransformGeometry node in hypergraph that are used after skinning. Note: do not share meshes in that case

Known Unsupported Features:
----------------------------

* (IMPORTANT!) skin and morph on the same mesh is not supported. Use the "Force Skin to Morph Animation" option to force morph animation over skin in order to export properly the animation, or separate your object in 2 meshes, one with skin animation and the other with morph animation.

* (IMPORTANT!) non planar or not concave faces are not supported and thus must be triangulated within maya before export.

* nurbs: please convert all nurbs surface to polygon before export.

* place2dTexture node's parameters (Coverage, Translate Frame, Rotate Frame, Wrap, Stagger, Noise UV, Fast, etc...).

* bezier keyframed animation with "Fixed" tangent type, and bezier rotation and scale keys.

* morph animations are always sampled, the exporter cannot yet detect when morph keys are set.

* scale pivots are not supported.

* a mesh shared by several object having different rotate pivot.

* the shearing components of animated objects with manually set shearing (ie not resulting from hierarchy and non-uniformly scaled parents) is not supported

* textures with network paths are not exported.